Page tree
Skip to end of metadata
Go to start of metadata

Question

What Java versions does Unanet support?

Solution

As of Unanet v11.0, any of the following versions of Java are supported:

Java VersionKnown Issues

Oracle Java 8

N/A
Oracle Java 11

Issue: Display issue with accounting currency format for negative numbers.

Workaround: Set the java.locale.providers system property to list the data sources such that COMPAT is the first preference.

-Djava.locale.providers=COMPAT,SPI,CLDR,HOST

Steps:

  1. Open the Tomcat Configuration.
  2. Click on Java tab, set the property under Java Options as shown in the image below. 
  3. Click Apply and OK.
  4. Restart Tomcat.

OpenJDK 11

Issue: Display issue with accounting currency format for negative numbers.

Workaround: Set the java.locale.providers system property to list the data sources such that COMPAT is the first preference.

-Djava.locale.providers=COMPAT,SPI,CLDR,HOST

Steps:

  1. Open the Tomcat Configuration.
  2. Click on Java tab, set the property under Java Options as shown in the image below. 
  3. Click Apply and OK.
  4. Restart Tomcat.


As of Unanet v10.3, we no longer support Java 1.7.

For Java versions supported for Unanet v10.3 , please refer to Unanet 10.3 System Requirements Page.

Additional Information

For more information on the java.locale.providers property, please refer to the Oracle Java documentation.


  • No labels